Cannot format Harddrive. App disconnects when attempting to perform format

I just got Tablo 2-turner DVR, HD Antenna, and WD 1TB Elements Portable External Hard Drive - USB 3.0 today and set it up as the instructions dictated. Once I got to the Tablo setup, it found the antenna and searched for channels properly, but once it hit the Format HD page, the app quickly (before I could do anything) changed to a “Reconnecting” page and then completely missed the HD formatting. If I unplug the HD and plug it back in, it does the exact same thing - flashes the Format page at me and then straight to the Reconnecting screen. I’ve already checked and my HD is on the list of HDs that supposedly work with Tablo.

Any suggestions? Could I format the HD from my computer in some manner that will work?


@cmccarthy That drive should be fine - is it, or its cable at all damaged?
Send a note to our support team, and we can take a look.

I solved the issue myself. I can’t explain why it worked, but I formatted the drive on my PC as ext3 and then the next time I plugged it into the Tablo I was able to have Tablo format it properly.


1 Like

Interesting. Glad to hear that you’re up and running.

I just got a quad and installed a 2TB drive. Tried multiple things but could not get it to format. After I read the post from cmccarthy I removed the drive and tried to format it on my PC, no luck. So I tried to connect it to the USB port and plug the Tablo back in. This time the format option came up and now the drive is formatting. When it is done I will try plugging it into the internal slot and see if it works.

How are you connecting the drive to the USB port? Are you using an SATA to USB HDD enclosure?

I am using a SATA to USB HDD enclosure. So far it is working fine. At some point I will try plugging the drive into the internal jack and see how that works.

Hopefully it works. The Tablo wasn’t designed to take external drives that are connected via USB and then put them internally. Let us know.

I switched the drive from the USB to the SATA and everything is working. The recordings I had are still there and they playback.