Can’t connect via Wi-Fi to hardwired Tablo Quad

Had a weird issue pop up recently. My Tablo is connected to my home network via Ethernet. All of my Roku’s that are connected via Ethernet work just fine. My one Roku Stick and my iPhone, however, will not connect. While I can see the Tablo on the network, I get the following error:

“A connection to your Tablo could not be established. Please check your internet connection.”

I’ve already tried all of the troubleshooting suggestions. Reset Tablo, Power Cycle Tablo, Power Cycle/Reset Router, Uninstall/Reinstall Tablo App. Nothing has worked. Any ideas?

Something to check, some routers disallow connections between the hardwired and wireless network.

Did the Roku stick and iPhone ever connect wirelessly to your wired Tablo? You might try changing one of your wired Roku devices to wireless to see if it loses its Tablo connection. I had a similar problem years ago with a different media application and I believe it was a router setting that was causing it so that wired vs. wireless devices could only see their counterparts on the network, and not the other type. I believe it was the ‘group ICMP’ setting. You might try toggling it if your router has that setting to see if it makes a difference.

One more thing to check is that your Roku and/or iPhone aren’t connected to your ‘guest’ network. That allows external internet access but not device-to-device communication.