Buffering issues: will hardware correct this?

Issue: Initial recorded show launch has slow buffering, show will stop 3-4 times every 30 minutes to buffer, and slow to resume watching show after fast forwarding thru commercials. Often I get caught in a “loop” where the show will keep looping a 5 second clip and keep playing that over and over. If I pause for a minute, it seems to catch up and start playing better.

Setup: Tablo 2-tuner, new Roku 3, Netgear N600 router, 1tb drive (less than 10% full). Tablo is directly connected to router with cable and Roku 3 is on 2.4ghz wifi with strong signal (5ghz seems to be iffy)

Questions:

  1. Is my router my bottle neck? Is there some settings I should try to change?
  2. Would hardwire connection to Roku solve this issue? I can do this, but requres running cable outside of house to get to the tv and I want to make sure before i do that!

Thanks!

Also, everything (Roku, Tablo, Router, Roku Channel) is on latest versions/firmware

xxxx cccc xx cc

Thanks…just trying to see. It’s going to be a bit of a pain to run it outside.

I guess I could test by just running the cable through the house just to test. I’m sure the wife will love that!!! :smile:

Also for got to say I am using the 720/Roku recording settings on the Tablo

I was going to suggest switching to 720p on the Tablo, but if that didn’t fix it then try hardwired. Sometimes the best WiFi signal still isn’t enough. Being hardwired should give you 80 megabit max throughput. (100mbit - 20% overhead)

If the Roku is located far from your router, and if you have neighbors with wi-fi, there might be an interference problem, in which case, you might be able to used a fixed, different channel for wi-fi. If you’re able to, as a test you might try moving your TV & Roku right next to your router to see if that makes a difference in performance.

I thought my old router was pretty decent, but recently replaced it with a TP Link Archer C7, and noticed an immediate performance improvement, not only with Tablo but also with some of my connected devices. It’s easy enough to buy a router and try it, and if you see no improvement, you could return it.

1 Like

Hardware makes all the difference with Tablo. I started out with a crappy router with a Roku 3, constant buffering mid stream. Then I started using Powerline adapters which cut down most mid-stream buffering but had to be reset too often. Then I got rid of Powerline and upgraded my router to the Archer C7, which got rid of mid-stream buffer but still left me about 4-10 seconds of buffering starting recordings, or fast forwarding through commercials. Then I switched from Roku 3 to NVIDIA Shield TV (an Android TV box) and I get no buffering at any in the UI or Recordings playback.

TL;DR - I have noticed MASSIVE differences in buffering based on my hardware configuration. If something doesn’t work for you but you love Tablo, if you are willing to spend some time and money you should.

@darthdennis - All good suggestions above although the ‘loop’ you’re seeing in Roku is usually due to a poor signal from the antenna so you may wish to tweak that first.

wired is always better, but I would wait for the next tablo firmware release before investing too much.

You can also apply to be part of the beta to see if the upcoming firmware seems to address your issue.

I personally could never get Roku 3 to play smoothly, wired or wireless, with different routers and a ton of testing. Apple TV and iPad has always worked perfectly for me.

I can watch the same recording, on the same WiFi signal, in the same room as the Roku on an iPad and have no looping or buffering issues.

Is there something wrong with the Roku or Roku Channel? (tried both the full and the beta release versions of the Roku channel)

@darthdennis - the iPad can receive a higher bitrate of info than most Rokus but it should be able to handle the 720 setting.

I’d touch base with support so they can help you troubleshoot this problem.