Brand new out of the box. Nothing will connect

Hi everyone. I’m a little dumbfounded and frustrated that this didn’t just “connect” right out of the box. I’ve seen that most of the people on here have an IT background. I’ve also been in the industry for the last 25 years.

It’s plugged into my network at the main switch, which is also where the router to the internet is plugged in. It picks up an IP address and I can ping it, and I can Telnet to it.

Nothing in the app world can seem to connect to it for actual viewing and configuration. I can get to it with the Android app on my phone and add it via WiFi. It reboots and connects to the access point, but the FireTV app can’t find it, and no configuration screens are coming up from anything.

I’ve done the factory reset, moved it to a different port on the switch, moved it to a different switch in the house, connected to a different access point. The results are the same in all cases.

Any ideas?


Can you get to the Tablo via a web browser? The app on the FireTV and your Android device would be the same app, so it’s odd that you can connect w/ one and not the other.

Connecting directly to the IP address yes, I get the Nuvyyo Tablo Server page.

xxxx cccc xx cc

Yes. Thought of that this morning. Enabled and rebooted everything. No joy.

You using any think to trick dns to think you’re in another country? Do you have any ports blocked? Does resolve?

What happens if you try ?

That is the correct way to connect

Put your phone on your wifi and look for Tablo##### and connect to it. Then format hd.

His Tablo is hardwired to the router, so I don’t think that will work. That step only works if the Tablo is wireless as well.

My Tablo arrived yesterday and had the same type of problem. I could see the Tablo connected to my router using both wired and wifi, but I finally just had to give up. I was never able to access the start up screen on the unit. Returning the unit to Amazon today.

PS: And I attempted setup using both the Android and the PC app without success numerous times.

Returning your unit without seeking any kind of technical support seems pretty drastic, doesn’t it?

1 Like

Yes, and I had high expectations for the Tablo. I have and have had many network devices that worked flawlessly out of the box and I simply did not have time to keep tinkering with it and maybe eventually get it to work. I have already ordered a similar unit. I will likely consider purchasing another Tablo in about a year as I felt that the Tablo was exactly what I was looking for.

Well I guess if hsco36 can access the router and see the tablo connect, but can’t describe anything about the client connect results, doesn’t check to see if the various devices are on the same sub-net, and doesn’t contact support. Anything might be considered drastic.

Same situation as hcso36. Bought it from Amazon, can see it on the network, can’t get to any configuration pages.


  • Browser to the ip address - worked
  • Telnet to it - worked
  • Ping it - worked
  • Connect through Android phone over wifi - can’t find it
  • Connect through FireTV app - can’t find it
  • Connect through - can’t find it
  • Enabled UPnP - no change
  • Reboot everything in the house - no change

It’s almost sounding like the units from Amazon are defective.

1 Like

Got mine from Newegg

And the android phone, firetv, clients are all on the same sub-net (IP address) as the actual tablo server.

I have the exact same thing happening and can’t get Tablo support to call me back. Had them on the line and we tried some basic resets and they said they would have to get back to me and still no word. Very disappointed with them and can see why sending back seems as best option.

Hey there folks - we have confirmed there’s an issue with our back-end servers for brand new connections. The hardware itself is A-OK.

We’re working on a hotfix for this. In the meantime, there is a workaround but it requires some assistance from support so please touch base with them and they’ll get you up & running.

@hcso36 @fililr

**** UPDATE - The fix is in so please reboot your Tablo and try to connect again.****


Went to pick up the kids from school. Came back and watched a movie on Hulu and decided to try again. The Tablo came to life and seems to be doing fine so far.

If it were me, I would put in a fallback option for the Tablo when there are issues connecting to the backend servers. Limit some functions if it can’t “phone home” but don’t make it a paperweight if it can’t.