AppleTV 4K app fails to connect to Tablo Dual HDMI

When I first bought my AppleTV 4k streaming device, I could connect to my Tablo Dual HDMI via wired Ethernet. Now, it will not find nor connect to the Tablo on the network.

I have two FireTV enabled Smart TVs and the app will connect to the Tablo with no issues. I have two Roku Ultra devices, and again no issues connecting to the Tablo.

Try the AppleTV 4k Tablo app… and… no connection. I don’t know if Apple pushed a new firmware update and broke the Tablo app or what the deal is.

I have even deleted and reinstalled the Tablo app on the Apple and am met with the same issue.

Any assistance in this matter would be appreciated.

1 Like

I can’t explain how you were able to connect to your Tablo HDMI in the past since according to Tablo’s web site Apple TV’s aren’t supported for streaming. See below:

TV-connected Tablo DVRs are designed for cord cutters who primarily watch programming on a single television.

However, once set up on your main television, streaming to a limited number of secondary televisions within the home is supported via:

  • Roku set-top-boxes and Smart TVs
  • Amazon Fire TV set-top-boxes and Smart TVs
  • Android TV streaming devices and Smart TVs

That’s weird because the AppleTV 4k has a downloadable Tablo app from their App Store and it worked previously. Did Tablo drop support for Apple streaming products?

As far as I know, Tablo has never supported streaming to Apple TV units from Tablo HDMI units. The app is only for network connected Tablos.

Again, that’s very strange. I wonder if they did a trial run and then stopped. It did connect the first time I loaded the app.

had the same issue with tablo quad ota dvr, rebooted, everything is working now. have you tried to reboot your tablo hdmi???

I have rebooted the Tablo. Same issue. It’s really frustrating.