Android App requires 4.1+

Recent cord cutter here. I’m enjoying my Tablo which works extremely well.

Part of my planning when I bought it was to take advantage of two Kindle Fire HD tablets that I already had. Sadly, once I got everything working and went to install the Tablo app I found that my devices are not supported. They run Fire OS 7.5.1 which equates to Android 4.0.3.

I now see that it’s very clearly stated that Android 4.1+ is what is required at My bad for missing that.

Support: if I side loaded the Tablo app onto my tablet, would it run with some missing functionality, or just not run at all? I figured I’d ask. (Though I probably spent more time typing this post than just giving it a shot!)

There is a Fire TV tablet version (might still be beta) @Tablotv can you help him out?

Side loading Android works but you will see some messages about something not found. Just click on and go on. I have one of those $50 tablets

Beastman thanks for the suggestion and shout out to Tablo support regarding a Fire TV tablet beta version.

I attempted to side load Tablo_1.0.25.apk and receive “Parse Error:There is a problem parsing the package” when trying to install. So, I’m dead in the water.

IMHO, it’s one of the biggest problems with Android. While I commend Tablo for support an old version like 4.1, obviously there are devices even older than that. Sigh… I don’t know about the rest here, but I’ve been forced to throw away many an Android device simply because the OS couldn’t be updated beyond a certain level. Starting with 2.3, then 3.0, etc.

With that said, I’m not sure if there’s a “good” answer for this problem.

One good thing about Nexus Player and Nexus 9 Tablet is no company’s “add ons”. Android the way it was developed

If Chrome brouser is working on a Kindle Fire?, you could run Tablo from Chrome brouser, I was doing that with my old android tablet.
I had to use a external video player, since at that time the Tablo video player wasn’t working on my tablet.

I feel your pain. When I first setup my Tablo, I could not run it on my Fire HD tablet because it was too old and didn’t have the proper OS. When they came out with the new models with an updated OS, I bought the 10" Fire, but while I could install the Tablo app, video would not play. Supposedly, Tablo was working on an update for the new Fire tablets, but I didn’t want to wait, so I returned it. I don’t know if that update ever came out. Unfortunately, because the Fire OS is not pure Android, Tablo has a special app just for Fire Tablets - so it is not just the version of Android, but also the version of FireOS that matters.

Note that I also could not get the Tablo web app or the Plex app with Tablo channel to play Tablo content on the newer Fire tablet. On my older Fire tablet, I could use the Plex channel to watch video - but it only worked with recordings (I am pretty sure this was the way it worked, but it could be I have it backward and it only worked with live TV).

I now use a Samsung Galaxy Tab S 10.5" (the older widescreen model) and it works fantastic with Tablo and all my other video apps (Plex, Amazon Video, Netflix, SlingTV, etc). It was very pricey, however, but everything works seamlessly.

Obviously “new & shiny” works. And is a solution of sorts. Even Samsung and even Nexus suffer from the deprecation problem.

The .apk I tried to side load was from Google Play. I got it from off my phone. Maybe that’s why I get the Parse error and cannot install. I’d like to try side loading the .apk from Amazon, but I have no way to get it…

I think I’m at a dead end. I just found this thread. Support says it won’t work. I’d still try it anyway if I had the .apk.

I’m taking an educated guess here but the problem is two fold with the Kindle. The major issue and why the requirement is 4.1 is due to the change in the use of Google Play Services. Tablo most likely relies on some of them for the Android app to function. So my guess would be that you would need both at least 4.1 and Google play services, which wouldn’t be supported anyways. Again just a guess. I would look into rooting and flashing a Google version of Android on it .

It is not always “new and shiny” that works, though. The 10" Fire tablet that I bought was brand new and was built off a compatible version of Android, but because of Amazon’s altered OS, it would not work. The Samsung that I replaced it with was a model they were getting rid of because it had been just replaced with something newer. In that case it was the older model using the standard operating system that worked.

I like the affordability of Amazon’s tablets, but the custom OS can be a real pain. Side loading is a pain and some apps just do not work on it. I have had that problem with Tablo and also with Insteon (home automation software - the version on Amazon is outdated and won’t work with hubs that work with the newest app version). If your tablet is just used for killing time and one entertainment app can be substituted with another, then Fires are great. But if you are a more power user, then you are better off sticking with the standard Android OS. Yes, it will become outdated with time, but at least most apps in their most current release can be found in the Google Play Store.

That’s very interesting (in a bad way) that the Tablo app available from Amazon won’t work with it’s flagship 10" Fire tablet. I was just pricing Fire tablets an hour ago specifically to be able to run Tablo on it.

Support: can you confirm that the current Fire tablets work with the Tablo app? Have you tested them?

I went to the Amazon app store and the current version says the following:

Latest Updates
What’s new in version Varies by device •Adds support for new Fire Tablets.

So it looks like the current version of the app may be compatible now. I cannot confirm because I did not keep my 10" as I did not want to wait.

We do actually have some of the brand new Fire tablets here at Tablo HQ for testing and the latest & greatest does have a fork specifically for them.

@MJL - Sorry your older Kindle isn’t compatible :frowning:

I was able to achieve some success in playing recordings by using in the Silk browser. I get a message that Flash isn’t present. There is a link that I select which looks like a url to the video. A tiny box pops up with a Play icon and after selecting it the video plays fine.

How is the video playing if the Silk Browser doesn’t have Flash? I’m curious.