After 2.20 update web does not work

Neither firefox or IE will connect with my tablo after the update. It goes to connecting then never connects.

Same on Firefox on Mac. It does work on Safari for Mac. Normally don’t use it but have to to access Tablo

Have you tried clearing cache on the browsers?

Tablo’s web app is designed and tested for use with Chrome or Safari.

Other browsers may not have the technology required for Tablo to work properly.

So has the WEB app changed since April 11th or are you saying users have just been lucky for the last few years or that the WEB app design is not dependant on being conformant to any HTML standard.

1.5.0 build 871 [201804110952]

Primarily has to do with browser support of WebSQL which was never really pushed as something “required” by browsers. If it had gained traction, especially in Windows and obviously, now, Edge, maybe it would have gained some traction in browsers like Firefox. The competing “standard” (don’t you just hate that word?) is an IndexedDB, which of course is not SQL. Sigh… just a mess.

With that said, thanks to the new Tablo api approach, more things are doable on Firefox than before, but it still needs a lot of work and it’s easier to have the evils of “sync” and WebSQL which means just Chrome and Safari pretty much.

1 Like

So you are saying that something changed in 2.2.20 to make the WEB connect flow break due to WebSQL? Or that tablo is (still) using WebSQL.

Or that the WebSQL standard has not been updated since 2010 which means it’s deprecated. And that IndexedDB is the W3C recommended standard. That IndexedDB has better support for JSON objects. And that Mozilla(Firefox) was the organization that pushed for adoption of IndexedDB.

And while it’s not clear that android supports IndexedDB. The other major browser do. And didn’t Firefox abandon WebSQL years ago. Which makes you wonder how Firefox worked with tablo before 2.2.20.

My testing bears that out as well… on 2.2.18, Edge, Firefox and Chrome browsers all worked on Win 10 computers. Now, only Chrome will connect to Tablo. So, something happened to Firefox and Edge browsers after the latest update, but to be fair, I don’t know that they were ever officially supported. I believe they didn’t work with earlier Tablo firmware as well, but my recollection as to exactly when is a little hazy.

Can’t say. I don’t have the lastest Tablo fw. So my Firefox works as well as it did before (which is really not all that well to be honest).

So what I seem to be hearing… We broke it … go to chrome…(yeach)… At least the app in W10 still works

I guess in Canada “Not fully supported” is a secret phrase for “doesn’t work at all”. Especially if you truly can’t connect. Maybe they need to finally update some WEB documentation


  • Not fully supported on all browsers - optimized for Chrome and Safari

Can the firmware be rolled back to 2.18?

I was also sad to learn I can’t use Firefox anymore after the latest patch.

I wonder if Tablo has plans to move off defunct WebSQL standard and onto the better IndexedDB that modern browsers use.

If you believe that the Firefox browser stopped working in 2.2.20 due to sudden lack of supprt of WebSQL, you can always google firefox and WebSQL and see if there is a WebSQL plug-in.

You might also be able to determine how many years and FireFox versions WebSQL hasn’t been supported.

It’s not quite that simple. WebSQL is supported and likely will be supported forever by Chrome and we’ll say also, Safari. But it’s the first one that is “bothersome” if you will. Because many consider Chrome to be the “only” viable browser out there. And of course Safari == Apple which “wins” just because Apple can do anything and win.

With that said, WebSQL didn’t get traction outside of that. And IndexedDB, as you mention has traction across multiple browsers (but not yet baked in most).

Anyway, I expect some semblance of support to come back perhaps in a near future update of Tablo software for Firefox and possibly others.

A possibly better answer is a sync’d db local on the device, but maybe that means a whole next-gen device.

If you have used tablo for a number of years then you know that there has been any number of times that WEB connect worked but subsequent Sync didn’t. Here the connect doesn’t even work.

If we assume that if WebSQL is the culprit then tablo OS 2.2.20 introduced WebSQL since the various browsers worked before 2.2.20.

Then should we also assume that tablo has architecture and high level design specifications. And that someone is approving design changes.

If a developer suggested switching to WebSQL, modifying the database design, etc, that someone should be investigating the state of WebSQL - feature content, various versions, what browsers it works on, state of future versions.

A big red light should have gone off on making any investment in that technology. Let along that the test organization should have flagged the problem.

But tablo is a consumer product versus a commercial product.

If it were a commercial product used by company such as RBC, their CTO would be making the midnight call to the tablo CEO ripping him a new one.

Various tablo employees would be surveying multiple worker cubicles that are about to become vacant…

Technology goes way back to Nuvyyo’s roots. They were merely leveraging what they already owned.

So an update on an old thread … I too was seeing Firefox not work. Recently, I had a different issue crop up on my Win10. In Chrome, Facebook videos won’t play right. They play, but it’s all oversized, blurry, black-n-white and unwatchable. For grins, I tried the native Tablo app and it looks similar. So, in Chrome and it’s a trifecta of not watchable video.

So pulled up FF and went to facebook and and a) it connects again, and b) it plays the video fine. So not sure what was up a few weeks back where FF would not work, but it does now! Yipee!

I suspect my issue with Chrome / Tablo app is local since I have a Linux box with Chrome and and FB videos work fine in Chrome on that.

Love the mystery that is modern tech that works one day, not another, then works again … At least I have a working option still! :wink:

1 Like