About to torch my tablo!

I’ve about had it with my 4 tuner tablo. When watching on roku, in any given room, we CONSTANTLY get “Loading, please wait” to the point it’s unwatchable. I know it’s not my network or my rokus (2s and 3s) as plex and Amazon stream perfectly fine without issue. We’ve tried changing the broadcast channel, moving the router, rebooting over and over, etc - I’m ready to throw the towel in. When it works, it’s amazing; unfortunately that’s a rare occurrence. What’s the deal Tablo?

I have had similar issues with my Roku2 XS when I had my recording quality set to 1080, I changing to 720 and the buffering problem went away.  The latest software release also includes a new 720-Roku recording quality option (uses a slightly lower bitrate than the 720 setting).

If you are using wireless you might not have a fast enough wifi  or you may have spotty reception … I use powerline 500 (ethernet over power) adaptors and not wifi and have no problems as they provide a fast enough connection and are not affected by interference like wifi can be … (i.e. neighbors wifi using the same channels as you, microwave ovens. etc)

this is what i use they are cheap and work well … but other brands are good too


@woodspot - Sorry you’re having issues with your Tablo. Before you break out the matches, please try the new Roku/Chromecast streaming quality. It should resolve your problem. Please note though that this will be applied to NEW recordings not the older ones. 

You can also place a ticket w/ @TabloSupport who’ll be happy to help out.


I am assuming the Tablo doesn’t dynamically stream based on connection bandwidth/quality.  Other devices services do.  Consequently if it is not getting the bandwidth it expects then it will give those messages.  Maybe this has been resolved in the latest version of the firmware?

When possible,  use ethernet instead of wifi.  I need had a loading issue with Tablo to Roku3 when ethernet connected.


I am experiencing the same issues as woodspot - I am using Roku 3 with an ethernet connection via a Powerline 500 and have already switched to 720 Roku recording setting. Both Live TV and recordings - with both new and old settings - are unwatchable since the firmware update came out. I had more success watching the recordings prior to the firmware upate. All my other Roku apps load fine. I already had a pending ticket that I’ve been back and forth with David on. I definitely empathize with woodspot as my Tablo is basically going unused right now. I’m doing my best to sell the wife on cutting the cord but at this point I don’t even want to make the move.

@woodspot Did you get a chance to try the Roku/Chromecast video setting? You can make the switch in the Tablo Settings menu under ‘Recording quality’. Let me know if this helps.

@marcduke Just a a different kind of test, could you give your Roku a direct connection to your router instead of via Powerline?

That’s not really an option where my Roku is located. I guess I’m confused how all other Roku apps(i.e. Netflix, PBS, Smithsonian, Watch ESPN) are running correctly, for both live or recorded programs and in full HD, via the same connection the Tablo is on.

@marcduke The Tablo does video quite differently than streaming services like Netflix, check out this thread for full details.

We really didn’t change anything for playback in 2.1.16 other than introducing the new recording quality, which is entirely optional.

How full is your hard drive? Could it be that it’s time to clear it out?